What’s Vulnerable › Vulnerabilities
CVE-2026-48489: Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-16
- Weakness: CWE-863
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, DefaultAuthenticationFailureHandler honored the request-supplied _failure_path parameter when failure_forward: true was enabled, allowing an unauthenticated failing login request to dispatch a subrequest to access_control-protected GET routes that skipped firewall listeners. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.
Affected products
- symfony: before 5.4.53; from 6.0.0 before 6.4.41; from 7.0.0 before 7.4.13; from 8.0.0 before 8.0.13 — fixed in 5.4.53, 6.4.41, 7.4.13, 8.0.13
How to fix
Upgrade to a fixed version: symfony 5.4.53, 6.4.41, 7.4.13, 8.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/c48a4276309e11aedeeb0ce3a89dfbf0b4fe04ff
- https://github.com/symfony/symfony/releases/tag/v5.4.53
- https://github.com/symfony/symfony/releases/tag/v6.4.41
- https://github.com/symfony/symfony/releases/tag/v7.4.13
- https://github.com/symfony/symfony/security/advisories/GHSA-6h46-9jf5-q59x
Get alerted when CVE-2026-48489 or the next vulnerability affects your stack