What’s Vulnerable › Vulnerabilities
CVE-2026-48493: Snipe-IT Vulnerable to Privilege Escalation for self via API Permissions Assignment
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-25
- Weakness: CWE-863
Description
Snipe-IT is an IT asset/license management system. In versions prior to 8.6.0, a user with only users.edit can send a PATCH to /api/v1/users/{their_own_id} and grant themselves any permission except admin and superuser — for example `assets.view`, `assets.create`, `reports.view`, import, etc. The issue is patched in version 8.6.0.
Affected products
- grokability snipe-it: before 8.6.0 — fixed in 8.6.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/pull/19024
- https://github.com/grokability/snipe-it/security/advisories/GHSA-52fw-7fw2-fmv5
Get alerted when CVE-2026-48493 or the next vulnerability affects your stack