What’s Vulnerable › Vulnerabilities

CVE-2026-4858: Path traversal in integration action URL leading to arbitrary API execution via system admin’s auth token.

Description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to check integration URL for path traversal which allows an malicious authenticated user to call an arbitrary API via system admin Mattermost auth token using via path traversal in integration action URL.. Mattermost Advisory ID: MMSA-2026-00640

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.15, 11.4.5, 11.5.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-4858 or the next vulnerability affects your stack