What’s Vulnerable › Vulnerabilities
CVE-2026-4870: Qiskit SDK is vulnerable to specific functions may recurse too deeply and overflow the available stack space, when encountering certain classical expressions.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-10-25
- Weakness: CWE-674
Description
IBM Qiskit SDK 0.43.0 through 2.5.0 could allow an attacker to trigger a segmentation fault leading to a denial of service due to uncontrolled recursion in the parser.
Affected products
- IBM Qiskit Software Development Kit: from 0.43.0 before 1.4.6; from 2.0.0 before 2.4.2 — fixed in 1.4.6, 2.4.2
How to fix
Upgrade to a fixed version: IBM Qiskit Software Development Kit 1.4.6, 2.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4870 or the next vulnerability affects your stack