What’s Vulnerable › Vulnerabilities
CVE-2026-48706: Envoy Heap Buffer Overflow in TcpStatsdSink
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-120
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. From 1.34.0 until 1.35.13, 1.36.9, 1.37.5, and 1.38.3, a vulnerability exists in Envoy's TCP StatsD sink (TcpStatsdSink), where the thread-local flusher buffer can be overflowed by exceptionally long statistic names (e.g., >16KiB). During formatting, TcpStatsdSink reserves a single contiguous memory slice of 16KiB (FLUSH_SLICE_SIZE_BYTES). If formatting a single metric exceeds the remaining capacity, the flusher initiates a buffer rotation but incorrectly continues to allocate another fixed 16KiB slice. If an attacker can trigger a statistic name longer than 16KiB—for example, by sending an HTTP or gRPC request with an extremely long request path (:path) that is recorded by the grpc_stats filter configured with stats_for_all_methods: true—the flusher will attempt to copy the metric name using memcpy operations beyond the allocated heap buffer boundaries. This leads to a heap write overflow, which can cause immediate denial-of-service (process crash) or potential remote code execution (RCE). This vulnerability is fixed in 1.35.13, 1.36.9, 1.37.5, and 1.38.3.
Affected products
- envoyproxy envoy: from 1.34.0 before 1.35.13; from 1.36.0 before 1.36.9; from 1.37.0 before 1.37.5; from 1.38.0 before 1.38.3 — fixed in 1.35.13, 1.36.9, 1.37.5, 1.38.3
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.35.13, 1.36.9, 1.37.5, 1.38.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-48706 or the next vulnerability affects your stack