What’s Vulnerable › Vulnerabilities
CVE-2026-48805: Twig: Sandbox state regression in deprecated internal wrappers in `src/Resources/core.php`
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-693
Description
Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.
Affected products
- twigphp Twig: before 3.27.0 — fixed in 3.27.0
How to fix
Upgrade to a fixed version: twigphp Twig 3.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/twigphp/Twig/commit/e235cae3a1d1e23edc24df4d675f18108c6b167b
- https://github.com/twigphp/Twig/releases/tag/v3.27.0
- https://github.com/twigphp/Twig/security/advisories/GHSA-p42q-9prx-q5wq
Get alerted when CVE-2026-48805 or the next vulnerability affects your stack