What’s Vulnerable › Vulnerabilities
CVE-2026-4881
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-04 · updated 2026-07-22
- Weakness: CWE-862
Description
In affected versions of Octopus Server, permissions were not checked correctly resulting in any authenticated user being able to make server level changes using a certain API endpoint despite receiving an error.
Affected products
- Octopus Deploy Octopus Server: from 2023.1.4189 before 2025.4.10545; from 2026.1.675 before 2026.1.11313 — fixed in 2025.4.10545, 2026.1.11313
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2025.4.10545, 2026.1.11313. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4881 or the next vulnerability affects your stack