What’s Vulnerable › Vulnerabilities
CVE-2026-48834: Apache Answer: Denial of service via crafted Accept-Language header parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-23
- Weakness: CWE-400
Description
Improper Handling of Length Parameter Inconsistency vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.1. Unauthenticated attackers can cause a denial of service via a specially crafted Accept-Language header that triggers excessive CPU consumption during parsing. Users are recommended to upgrade to version 2.0.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Answer 2.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/0yg5smwnbrhqs55m5h61gn42mcs8s95p
- http://www.openwall.com/lists/oss-security/2026/08/05/9
Get alerted when CVE-2026-48834 or the next vulnerability affects your stack