What’s Vulnerable › Vulnerabilities
CVE-2026-48840
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-30 · updated 2026-07-22
- Weakness: CWE-839
Description
Exim 4.88 before 4.99.4, in some proxy configurations, mishandles certain short payloads, leading to disclosure of uninitialized stack memory values to a client.
Affected products
- Exim: from 4.88 before 4.99.4 — fixed in 4.99.4
How to fix
Upgrade to a fixed version: Exim 4.99.4. Check the vendor advisory for mitigations.
References
- https://exim.org/static/doc/security/EXIM-Security-2026-05-19.1
- https://www.openwall.com/lists/oss-security/2026/05/29/3
- http://www.openwall.com/lists/oss-security/2026/05/29/3
- https://lists.debian.org/debian-lts-announce/2026/06/msg00004.html
Get alerted when CVE-2026-48840 or the next vulnerability affects your stack