What’s Vulnerable › Vulnerabilities
CVE-2026-48852
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-25 · updated 2026-07-24
- Weakness: CWE-617
Description
PuTTY 0.71 before 0.84 has an assertion failure in ECDSA signature verification.
Affected products
- PuTTY: from 0.71 before 0.84 — fixed in 0.84
How to fix
Upgrade to a fixed version: PuTTY 0.84. Check the vendor advisory for mitigations.
References
- https://lists.tartarus.org/pipermail/putty-announce/2026/000042.html
- https://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/ecdsa-remotely-triggerable-assertion.html
Get alerted when CVE-2026-48852 or the next vulnerability affects your stack