What’s Vulnerable › Vulnerabilities
CVE-2026-48863: Libsolv: stack-based buffer overflow in libsolv eddsa pgp signature verification allows denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-08-31
- Weakness: CWE-121
Description
A flaw was found in libsolv. A stack-based buffer overflow vulnerability exists in the PGP verification component due to incorrect length handling when copying EdDSA 's' MPI into a stack buffer. A remote attacker could craft a malicious Ed25519 PGP signature with mismatched MPI lengths. Processing this crafted signature could lead to a denial of service in automated package or repository processing workflows.
Affected products
- OpenSUSE libsolv: from 0.6.4 before 0.7.38 — fixed in 0.7.38
How to fix
Upgrade to a fixed version: OpenSUSE libsolv 0.7.38. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2026-48863
- https://bugzilla.redhat.com/show_bug.cgi?id=2460975
- https://github.com/openSUSE/libsolv/commit/44f8c085045b1f771641091bbb2b810d12cff9e8#diff-309f245ec9b669ec78b8159c39e6f50130b4d4a0448f742685f7833d04bc4caaR592
- https://access.redhat.com/security/cve/CVE-2026-48863
- https://bugzilla.redhat.com/show_bug.cgi?id=2460975
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-48863.json
Get alerted when CVE-2026-48863 or the next vulnerability affects your stack