What’s Vulnerable › Vulnerabilities
CVE-2026-4887: Gimp: gimp:memory disclosure and denial of service via specially crafted pcx image
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-193
Description
A flaw was found in GIMP. This issue is a heap buffer over-read in GIMP PCX file loader due to an off-by-one error. A remote attacker could exploit this by convincing a user to open a specially crafted PCX image. Successful exploitation could lead to out-of-bounds memory disclosure and a possible application crash, resulting in a Denial of Service (DoS).
Affected products
- GIMP: before 3.2.0; 3.2.0-rc1, 3.2.0-rc2, 3.2.0-rc3 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: GIMP 3.2.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:16484
- https://access.redhat.com/errata/RHSA-2026:17533
- https://access.redhat.com/errata/RHSA-2026:19362
- https://access.redhat.com/errata/RHSA-2026:20552
- https://access.redhat.com/errata/RHSA-2026:20553
- https://access.redhat.com/errata/RHSA-2026:20554
- https://access.redhat.com/errata/RHSA-2026:20691
- https://access.redhat.com/errata/RHSA-2026:25899
- https://access.redhat.com/errata/RHSA-2026:25901
- https://access.redhat.com/errata/RHSA-2026:25907
- https://access.redhat.com/errata/RHSA-2026:26168
- https://access.redhat.com/security/cve/CVE-2026-4887
Get alerted when CVE-2026-4887 or the next vulnerability affects your stack