What’s Vulnerable › Vulnerabilities
CVE-2026-4890: CVE-2026-4890
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-08-25
- Weakness: CWE-835
Description
A Denial of Service (DoS) vulnerability in the DNSSEC validation of dnsmasq allows remote attackers to cause a denial of service via a crafted DNS packet.
Affected products
- dnsmasq: before 2.92rel2 — fixed in 2.92rel2
How to fix
Upgrade to a fixed version: dnsmasq 2.92rel2. Check the vendor advisory for mitigations.
References
- https://github.com/NixOS/nixpkgs/pull/519082
- https://github.com/NixOS/nixpkgs/pull/519093
- https://github.com/pi-hole/FTL/releases/tag/v6.6.2
- https://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2026q2/018471.html
- https://thekelleys.org.uk/dnsmasq/CVE/
- https://www.kb.cert.org/vuls/id/471747
- https://access.redhat.com/errata/RHSA-2026:19158
- https://access.redhat.com/errata/RHSA-2026:19373
- https://access.redhat.com/errata/RHSA-2026:20589
- https://access.redhat.com/errata/RHSA-2026:34508
- https://access.redhat.com/errata/RHSA-2026:40762
- https://access.redhat.com/security/cve/CVE-2026-4890
Get alerted when CVE-2026-4890 or the next vulnerability affects your stack