What’s Vulnerable › Vulnerabilities
CVE-2026-48910: Apache JSPWiki: Markdown parser allows XSS injection in Markdown error processing
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-80
Description
A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the markdown renderer, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This issue affects Apache JSPWiki: through 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes the issue.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.4 — fixed in 2.12.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yvbdjnocw5qq3xkbjs9h77ghlg0bsw2c
- http://www.openwall.com/lists/oss-security/2026/07/30/18
Get alerted when CVE-2026-48910 or the next vulnerability affects your stack