What’s Vulnerable › Vulnerabilities
CVE-2026-48937
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-10-25
- Weakness: CWE-400
Description
A flaw in Node.js HTTP/2 server API can cause servers to keep accepting data even after sending a `GOAWAY` frame. This vulnerability affects two supported release lines: **Node.js 22** and **Node.js 24**.
Affected products
- Node.js: from 22.0 before 22.23.0; from 24.0.0 before 24.17.0 — fixed in 22.23.0, 24.17.0
How to fix
Upgrade to a fixed version: Node.js 22.23.0, 24.17.0. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/3658225
- https://nodejs.org/en/blog/vulnerability/june-2026-security-releases
Get alerted when CVE-2026-48937 or the next vulnerability affects your stack