What’s Vulnerable › Vulnerabilities
CVE-2026-48962: IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-08-05
- Weakness: CWE-95
Description
IO::Compress versions before 2.220 for Perl can execute arbitrary code in File::GlobMapper via an attacker-controlled output glob. _parseOutputGlob() wraps the caller-supplied output glob string in double quotes and stores it in the parser state; _getFiles() then runs the stored expression through eval STRING. A literal double quote in the output glob closes the dquote wrapper, and the characters that follow are evaluated as Perl. Arbitrary Perl in the output glob executes at the calling process's privilege.
Affected products
- PMQS IO::Compress: before 2.220 — fixed in 2.220
How to fix
Upgrade to a fixed version: PMQS IO::Compress 2.220. Check the vendor advisory for mitigations.
References
- https://github.com/pmqs/IO-Compress/commit/f2db247bf90d4cc7ee2710be384946081f3b4610.patch
- https://metacpan.org/release/PMQS/IO-Compress-2.220/changes
- http://www.openwall.com/lists/oss-security/2026/05/27/4
- https://access.redhat.com/errata/RHSA-2026:29182
- https://access.redhat.com/errata/RHSA-2026:29210
- https://access.redhat.com/errata/RHSA-2026:29867
- https://access.redhat.com/errata/RHSA-2026:29941
- https://access.redhat.com/errata/RHSA-2026:30085
- https://access.redhat.com/errata/RHSA-2026:30086
- https://access.redhat.com/errata/RHSA-2026:30115
- https://access.redhat.com/errata/RHSA-2026:30843
- https://access.redhat.com/errata/RHSA-2026:30851
Get alerted when CVE-2026-48962 or the next vulnerability affects your stack