What’s Vulnerable › Vulnerabilities

CVE-2026-49042: Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Camel 4.18.3, 4.21.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-49042 or the next vulnerability affects your stack