What’s Vulnerable › Vulnerabilities
CVE-2026-49095: Improper Input Validation in Kibana Fleet Leading to Privilege Escalation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-07-21
- Weakness: CWE-20
Description
Improper Input Validation (CWE-20) in the Kibana Fleet agent policy management feature can lead to privilege escalation. An authenticated user with Fleet management privileges can manipulate agent policy configuration by injecting values into a configuration override mechanism that is not adequately validated. An attacker can cause Elastic Agents to be issued API keys with elevated Elasticsearch privileges, potentially granting unauthorized read and write access to sensitive Elasticsearch security indices beyond what is intended for the Fleet management role.
Affected products
- Kibana: from 8.0.0 before 8.19.16; from 9.0.0 before 9.3.5; from 9.4.0 before 9.4.2 — fixed in 8.19.16, 9.3.5, 9.4.2
How to fix
Upgrade to a fixed version: Kibana 8.19.16, 9.3.5, 9.4.2. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/kibana-fleet-8-19-16-9-3-5-and-9-4-2-security-update-esa-2026-38/386559
Get alerted when CVE-2026-49095 or the next vulnerability affects your stack