What’s Vulnerable › Vulnerabilities
CVE-2026-49120: Medplum < 5.1.14 SSRF via FHIR Subscription Endpoint
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-02 · updated 2026-07-22
- Weakness: CWE-918
Description
Medplum before 5.1.14 contains a server-side request forgery vulnerability in the subscription worker that allows authenticated users to perform unauthorized internal network requests by creating FHIR Subscription resources with arbitrary endpoint URLs. Attackers can point subscription endpoints at internal addresses such as cloud instance metadata services, internal databases, or container orchestration endpoints to exfiltrate IAM credentials and patient health records via the POST body containing full FHIR resource payloads.
Affected products
- medplum: before 5.1.14 — fixed in 5.1.14
How to fix
Upgrade to a fixed version: medplum 5.1.14. Check the vendor advisory for mitigations.
References
- https://github.com/medplum/medplum/commit/87595e98d756d840d70d9dc87beb9d4f9e158b59
- https://github.com/medplum/medplum/pull/9334
- https://github.com/medplum/medplum/releases/tag/v5.1.14
- https://www.vulncheck.com/advisories/medplum-ssrf-via-fhir-subscription-endpoint
Get alerted when CVE-2026-49120 or the next vulnerability affects your stack