What’s Vulnerable › Vulnerabilities
CVE-2026-49131: OPNsense < 26.1.9 Stored XSS via Firewall Rule Description Field
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-10-23
- Weakness: CWE-79
Description
OPNsense before 26.1.9 contains a stored cross-site scripting vulnerability that allows authenticated attackers with firewall rule management privileges to inject arbitrary HTML or JavaScript by embedding payloads in the firewall rule description field via the filter API endpoint. The unsanitized description value is persisted and later rendered through the default cell formatter in opnsense_bootgrid.js, which assigns raw cell content to innerHTML, causing injected scripts to execute in the browser of any authenticated user who views the Firewall Rules page, enabling session hijacking or credential theft.
Affected products
- Deciso B.V. OPNsense: before 26.1.9 — fixed in 26.1.9
How to fix
Upgrade to a fixed version: Deciso B.V. OPNsense 26.1.9. Check the vendor advisory for mitigations.
References
- https://docs.opnsense.org/releases/CE_26.1.html#june-02-2026
- https://github.com/opnsense/core/commit/b11d6b340716e240868ab19a369e058a46f0876f
- https://www.vulncheck.com/advisories/opnsense-stored-xss-via-firewall-rule-description-field
Get alerted when CVE-2026-49131 or the next vulnerability affects your stack