What’s Vulnerable › Vulnerabilities
CVE-2026-49132: OPNsense < 26.1.9 Stored XSS via Certificate Description Field
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-10-23
- Weakness: CWE-79
Description
OPNsense before 26.1.9 contains a stored cross-site scripting vulnerability that allows authenticated attackers to inject arbitrary HTML or JavaScript by embedding payloads in the certificate description field via the trust certificate API. The unsanitized description value is persisted and later rendered in the Dashboard Certificates widget through Certificates.js, which interpolates the raw value into HTML attribute and text content sinks without encoding, causing injected scripts to execute in the browser of any authenticated user who views the Dashboard, enabling session hijacking or credential theft.
Affected products
- Deciso B.V. OPNsense: before 26.1.9 — fixed in 26.1.9
How to fix
Upgrade to a fixed version: Deciso B.V. OPNsense 26.1.9. Check the vendor advisory for mitigations.
References
- https://docs.opnsense.org/releases/CE_26.1.html#june-02-2026
- https://github.com/opnsense/core/commit/12b021ff11db38705e92ac4c9af5e07d602da6ba
- https://www.vulncheck.com/advisories/opnsense-stored-xss-via-certificate-description-field
Get alerted when CVE-2026-49132 or the next vulnerability affects your stack