What’s Vulnerable › Vulnerabilities
CVE-2026-49142: OpenEMR Before 8.5.0 SQL Injection via form_icd_codes[]
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-89
Description
OpenEMR before 8.5.0 contains an authenticated SQL injection vulnerability in the Syndromic Surveillance module that allows users with Clinician-level privileges to read and modify arbitrary database contents by submitting crafted values in the form_icd_codes[] POST parameter to the syndromicsurveillance/index endpoint. Attackers can inject an unquoted numeric IN() clause and UNION DISTINCT SELECT statement using hex-encoded literals to abuse MySQL extractvalue() for error-based exfiltration of bcrypt password hashes and execute stacked queries that reset passwords, resulting in full administrative account takeover.
Affected products
- openemr: before 8.5.0 — fixed in 8.5.0
How to fix
Upgrade to a fixed version: openemr 8.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/9b52cc0fc3a4eddd9fa7a096f6a3ac2a57d772d0
- https://github.com/openemr/openemr/pull/14329
- https://github.com/openemr/openemr/releases/tag/v8_5_0
- https://github.com/openemr/openemr/security/advisories/GHSA-w99c-jwcm-24hh
- https://www.vulncheck.com/advisories/openemr-before-sql-injection-via-form-icd-codes
Get alerted when CVE-2026-49142 or the next vulnerability affects your stack