What’s Vulnerable › Vulnerabilities

CVE-2026-49157: Apache ActiveMQ: Authenticated low-privilege Web users retain Jolokia broker-management capability by default

Description

Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache ActiveMQ 5.19.7, 6.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-49157 or the next vulnerability affects your stack