What’s Vulnerable › Vulnerabilities
CVE-2026-49218: ImageMagick: Policy Bypass in DCM decoder could result in image with invalid dimensions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-20
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-48 and 7.1.2-24, a missing check in the DCM decoder could result in an image with invalid dimensions and that could cause crashes in other operation. This issue has been patched in versions 6.9.13-48 and 7.1.2-24.
Affected products
- ImageMagick: before 6.9.13-48; from 7.0.0-0 before 7.1.2-24 — fixed in 6.9.13-48, 7.1.2-24
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-48, 7.1.2-24. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8pj9-6897-74xc
- https://access.redhat.com/errata/RHSA-2026:32961
- https://access.redhat.com/security/cve/CVE-2026-49218
- https://bugzilla.redhat.com/show_bug.cgi?id=2487763
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49218.json
Get alerted when CVE-2026-49218 or the next vulnerability affects your stack