What’s Vulnerable › Vulnerabilities

CVE-2026-4922: Cross-Site Request Forgery (CSRF) in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.0 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that could have allowed an unauthenticated user to execute GraphQL mutations on behalf of authenticated users due to insufficient CSRF protection.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.4, 18.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-4922 or the next vulnerability affects your stack