What’s Vulnerable › Vulnerabilities

CVE-2026-49230: Apache APISIX: Authentication bypass in jwe-decrypt

Description

Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass.  This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-49230 or the next vulnerability affects your stack