What’s Vulnerable › Vulnerabilities

CVE-2026-49231: Apache APISIX: Identity spoofing issue in APISIX opa plugin

Description

Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-49231 or the next vulnerability affects your stack