What’s Vulnerable › Vulnerabilities
CVE-2026-49270: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: Durable Subscription Disclosure via Crafted BrokerInfo (OpenWire)
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-01 · updated 2026-07-22
- Weakness: CWE-1230
Description
Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.7; from 6.0.0 before 6.2.6 — fixed in 5.19.7, 6.2.6
- Apache Activemq Broker: before 5.19.7; from 6.0.0 before 6.2.6 — fixed in 5.19.7, 6.2.6
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.7, 6.2.6; Apache Activemq Broker 5.19.7, 6.2.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/k3233c1x506z3w7x4z0dqvd86d4v2fr2
- http://www.openwall.com/lists/oss-security/2026/05/31/22
Get alerted when CVE-2026-49270 or the next vulnerability affects your stack