What’s Vulnerable › Vulnerabilities
CVE-2026-49364: Apache Artemis, Apache Artemis, Apache ActiveMQ Artemis, Apache ActiveMQ Artemis: Pre-Authentication Cluster Credential Exposure to Discovered Peers
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-16
- Weakness: CWE-306
Description
An unauthenticated network-adjacent attacker can leverage discovery to capture cluster administrative credentials during the initial cluster connection handshake. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache ActiveMQ Artemis: from 1.0.0 before 2.44.0; from 2.50.0 before 2.57.0 — fixed in 2.44.0, 2.57.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ActiveMQ Artemis 2.44.0, 2.57.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4qbgcz3k38q30bfbf7hphtomrdc8l8n8
- http://www.openwall.com/lists/oss-security/2026/09/10/3
Get alerted when CVE-2026-49364 or the next vulnerability affects your stack