What’s Vulnerable › Vulnerabilities
CVE-2026-49434: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All: LdapNetworkConnector instantiates denied transports and a remote-properties broker
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-07-02
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.8; from 6.0.0 before 6.2.7 — fixed in 5.19.8, 6.2.7
- Apache Activemq Broker: before 5.19.8; from 6.0.0 before 6.2.7 — fixed in 5.19.8, 6.2.7
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.8, 6.2.7; Apache Activemq Broker 5.19.8, 6.2.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/hcjh7kdk4l85tb9ksmvcnkhso1ngj50o
- http://www.openwall.com/lists/oss-security/2026/06/29/8
Get alerted when CVE-2026-49434 or the next vulnerability affects your stack