What’s Vulnerable › Vulnerabilities
CVE-2026-49443: authentik: `UserSourceConnection.user` and `GroupSourceConnection.group` are changeable through the API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-02 · updated 2026-07-22
- Weakness: CWE-287
Description
authentik is an open-source identity provider. Prior to versions 2025.12.6, 2026.2.4, and 2026.5.1, an attacker with the ability to change a source connection, and an account in one of the configured sources can log into any account. This issue has been patched in versions 2025.12.6, 2026.2.4, and 2026.5.1.
Affected products
- goauthentik authentik: before 2025.12.6; from 2026.2.0 before 2026.2.4; from 2026.5.0 before 2026.5.1 — fixed in 2025.12.6, 2026.2.4, 2026.5.1
How to fix
Upgrade to a fixed version: goauthentik authentik 2025.12.6, 2026.2.4, 2026.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/security/advisories/GHSA-wr38-7xg8-fqxr
- https://github.com/goauthentik/authentik/security/advisories/GHSA-wr38-7xg8-fqxr
Get alerted when CVE-2026-49443 or the next vulnerability affects your stack