What’s Vulnerable › Vulnerabilities
CVE-2026-49476: Soup Sieve: Memory Exhaustion via Large Comma-Separated Selector Lists in soupsieve
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-400
Description
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve allocates unbounded memory when compiling large comma-separated selector lists, allowing an attacker who can supply a crafted selector string to soupsieve.compile() or Beautiful Soup .select() / .select_one() to allocate hundreds of megabytes of heap memory from a relatively small input and cause denial of service. This issue is fixed in version 2.8.4.
Affected products
- facelessuser soupsieve: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: facelessuser soupsieve 2.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/facelessuser/soupsieve/commit/28108ab805818c832d9568142a99844fd95a0d39
- https://github.com/facelessuser/soupsieve/releases/tag/2.8.4
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-2wc2-fm75-p42x
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-2wc2-fm75-p42x
Get alerted when CVE-2026-49476 or the next vulnerability affects your stack