What’s Vulnerable › Vulnerabilities
CVE-2026-49477: Soup Sieve: Regular Expression Denial of Service (ReDoS) in soupsieve Selector Parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-400
Description
Soup Sieve is a CSS selector library designed to be used with Beautiful Soup 4. Prior to 2.8.4, the CSS selector parser in soupsieve contains a regular expression vulnerable to catastrophic backtracking when processing an attribute selector with an unterminated quoted value in soupsieve/css_parser.py, allowing an attacker who can supply untrusted CSS selector strings to soupsieve.compile() or Beautiful Soup .select() / .select_one() to cause CPU exhaustion and denial of service. This issue is fixed in version 2.8.4.
Affected products
- facelessuser soupsieve: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: facelessuser soupsieve 2.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/facelessuser/soupsieve/commit/eb4397618709186c109400448c6043b728217dc3
- https://github.com/facelessuser/soupsieve/releases/tag/2.8.4
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-836r-79rf-4m37
- https://github.com/facelessuser/soupsieve/security/advisories/GHSA-836r-79rf-4m37
Get alerted when CVE-2026-49477 or the next vulnerability affects your stack