What’s Vulnerable › Vulnerabilities
CVE-2026-49871: Apache APISIX: cas-auth login CSRF / session injection issue
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-19 · updated 2026-10-26
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 3.0.0 before 3.17.0 — fixed in 3.17.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp
- http://www.openwall.com/lists/oss-security/2026/06/19/14
Get alerted when CVE-2026-49871 or the next vulnerability affects your stack