What’s Vulnerable › Vulnerabilities

CVE-2026-49872: Apache APISIX: Improper authentication in cas-auth plugin

Description

Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-49872 or the next vulnerability affects your stack