What’s Vulnerable › Vulnerabilities
CVE-2026-49877: Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-10-25
- Weakness: CWE-285
Description
Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.8; from 6.0.0 before 6.2.7 — fixed in 5.19.8, 6.2.7
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.8, 6.2.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/w82vtc3q02j5ot94tnyy1197y3wb98hl
- http://www.openwall.com/lists/oss-security/2026/06/29/9
Get alerted when CVE-2026-49877 or the next vulnerability affects your stack