What’s Vulnerable › Vulnerabilities
CVE-2026-4989
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-10-26
- Weakness: CWE-918
Description
Improper input validation in the gateway health check feature in Devolutions Server allows a low-privileged authenticated user to perform server-side request forgery (SSRF), potentially leading to information disclosure, via a crafted API request. This issue affects Server: from 2026.1.1 through 2026.1.11, from 2025.3.1 through 2025.3.17.
Affected products
- Devolutions Server: from 2025.3.1.0 before 2025.3.18.0; from 2026.1.1.0 before 2026.1.12.0 — fixed in 2025.3.18.0, 2026.1.12.0
How to fix
Upgrade to a fixed version: Devolutions Server 2025.3.18.0, 2026.1.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4989 or the next vulnerability affects your stack