What’s Vulnerable › Vulnerabilities
CVE-2026-49959: Hermes WebUI < 0.51.311 RCE via Git Configuration Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-78
Description
Hermes WebUI before version 0.51.311 contains a remote code execution vulnerability that allows authenticated attackers to execute arbitrary commands by placing malicious executable Git configuration in a workspace repository's .git/config file. Attackers can exploit Git subprocess invocations in api/workspace_git.py through vectors such as core.fsmonitor during git status, protocol.ext.allow with ext:: remotes during git fetch, credential.helper, core.askPass, core.gitProxy, or inherited environment variables including GIT_SSH_COMMAND to achieve arbitrary command execution on the host running the application.
Affected products
- nesquena hermes-webui: before 0.51.311 — fixed in 0.51.311
How to fix
Upgrade to a fixed version: nesquena hermes-webui 0.51.311. Check the vendor advisory for mitigations.
References
- https://github.com/nesquena/hermes-webui/commit/938ac9f55b53def1eefb48c4c42dabaf9c22e99c
- https://github.com/nesquena/hermes-webui/pull/3776
- https://github.com/nesquena/hermes-webui/releases/tag/v0.51.311
- https://www.vulncheck.com/advisories/hermes-webui-rce-via-git-configuration-injection
Get alerted when CVE-2026-49959 or the next vulnerability affects your stack