What’s Vulnerable › Vulnerabilities
CVE-2026-49969: Laravel-Mediable < 7.0.0 SSRF via RemoteUrlAdapter URL Handling
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-13 · updated 2026-10-24
- Weakness: CWE-918
Description
Laravel-Mediable before 7.0.0 contains a server-side request forgery vulnerability that allows remote attackers to issue arbitrary HTTP requests from the server by supplying unvalidated caller-controlled URLs to endpoints backed by MediaUploader::fromSource(). Attackers can craft URLs targeting RFC-1918 addresses, loopback interfaces, cloud metadata endpoints, or file:// URIs through RemoteUrlAdapter to reach internal infrastructure, retrieve sensitive files, and exfiltrate cloud credentials such as IAM tokens from instance metadata services.
Affected products
- plank laravel-mediable: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: plank laravel-mediable 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/plank/laravel-mediable/commit/7e9e3000fa05fe16e678f15bfb51a091e60c2cb8
- https://github.com/plank/laravel-mediable/releases/tag/7.0.0
- https://www.vulncheck.com/advisories/laravel-mediable-ssrf-via-remoteurladapter-url-handling
Get alerted when CVE-2026-49969 or the next vulnerability affects your stack