What’s Vulnerable › Vulnerabilities
CVE-2026-49975: Apache HTTP Server: mod_http2 denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 33.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-08 · updated 2026-08-19
- Weakness: CWE-789
Description
Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http leads to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server: from 2.4.17 through 2.4.67.
Affected products
- Apache HTTP Server: from 2.4.17 before 2.4.68 — fixed in 2.4.68
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.68. Check the vendor advisory for mitigations.
In the news
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/06/03/3
- http://www.openwall.com/lists/oss-security/2026/06/08/16
- https://lists.debian.org/debian-lts-announce/2026/06/msg00009.html
- https://access.redhat.com/errata/RHSA-2026:25042
- https://access.redhat.com/errata/RHSA-2026:25057
- https://access.redhat.com/errata/RHSA-2026:25090
- https://access.redhat.com/errata/RHSA-2026:25225
- https://access.redhat.com/errata/RHSA-2026:27114
- https://access.redhat.com/errata/RHSA-2026:27200
- https://access.redhat.com/errata/RHSA-2026:27201
- https://access.redhat.com/errata/RHSA-2026:36373
Get alerted when CVE-2026-49975 or the next vulnerability affects your stack