What’s Vulnerable › Vulnerabilities
CVE-2026-50016: pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-25 · updated 2026-06-29
- Weakness: CWE-23
Description
pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm allows a transitive dependency alias from registry package metadata to contain path traversal segments. During install, pnpm later uses that alias as a filesystem path when linking dependency nodes. As a result, a registry package can cause `pnpm install --ignore-scripts` to replace paths in the current project with symlinks to attacker-controlled dependency package directories. This vulnerability is fixed in 10.34.0 and 11.4.0.
Affected products
- pnpm: before 10.34.0; from 11.0.0 before 11.4.0 — fixed in 10.34.0, 11.4.0
How to fix
Upgrade to a fixed version: pnpm 10.34.0, 11.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-hwx4-2j3j-g496
- https://github.com/pnpm/pnpm/security/advisories/GHSA-hwx4-2j3j-g496
Get alerted when CVE-2026-50016 or the next vulnerability affects your stack