What’s Vulnerable › Vulnerabilities
CVE-2026-50095: BUG-000187165 - ArcGIS Server has a security vulnerability.
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-79
Description
There is a stored cross site scripting issue in Esri ArcGIS Server 11.1 and earlier on Windows and Linux that in some configurations allows a remote unauthenticated attacker to store files that contain malicious code that may execute in the context of a victim’s browser. A patch is provided for ArcGIS Server software in General Availability and Extended support status, which includes versions 12.1, 12.0, 11.5, 11.3, and 11.1. Other versions are in mature or retired status, which are not patch eligible. Users working with unlisted versions are advised to upgrade and apply the patch.
Affected products
- Esri ArcGIS Server: from 11.1 before 12.1 — fixed in 12.1
How to fix
Upgrade to a fixed version: Esri ArcGIS Server 12.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-50095 or the next vulnerability affects your stack