What’s Vulnerable › Vulnerabilities

CVE-2026-50096: BUG-000187164 - ArcGIS Server has a security vulnerability.

Description

There is a reflected cross site scripting vulnerability in Esri Portal for ArcGIS versions 12.1 and prior which may allow a remote, unauthenticated attacker to create a crafted link which when clicked could potentially execute arbitrary JavaScript code in the victim’s browser. A patch is provided for ArcGIS Server software in General Availability and Extended support status, which includes versions 12.1, 12.0, 11.5, 11.3, and 11.1. Other versions are in mature or retired status, which are not patch eligible. Users working with unlisted versions are advised to upgrade and apply the patch.

Affected products

How to fix

Upgrade to a fixed version: Esri ArcGIS Server 12.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-50096 or the next vulnerability affects your stack