What’s Vulnerable › Vulnerabilities
CVE-2026-50107: NGINX Gateway Fabric vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-10-26
- Weakness: CWE-74
Description
When NGINX Plus or NGINX Open Source is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the NginxProxy Custom Resource Definition (CRD) access log format setting are rendered directly into NGINX configuration templates without sanitization or escaping. An authenticated attacker with permission to create or modify these CRDs may craft values that inject arbitrary NGINX configuration directives. This is a control plane issue; there is no data plane exposure from the vulnerability trigger itself. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 2.3.0 before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-50107 or the next vulnerability affects your stack