What’s Vulnerable › Vulnerabilities
CVE-2026-50148: Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-07-30
- Weakness: CWE-73
Description
Metabase is an open-source business intelligence and embedded analytics tool. From 1.54.0 until 1.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10, and 1.60.4, a Metabase user with permission to add or edit a database connection can achieve remote code execution on the Metabase server by configuring a Snowflake connection to an attacker-controlled server, because a flaw in the Snowflake JDBC driver can write arbitrary files anywhere on the Metabase host, including replacing one of Metabase's own database driver files that later executes inside the Metabase process. This issue is fixed in versions 1.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10, and 1.60.4.
Affected products
- metabase: from 1.54.0 before 1.54.24; from 1.55.0 before 1.55.24; from 1.56.0 before 1.56.25; from 1.57.0 before 1.57.19; from 1.58.0 before 1.58.14; from 1.59.0 before 1.59.10 — fixed in 1.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10
How to fix
Upgrade to a fixed version: metabase 1.54.24, 1.55.24, 1.56.25, 1.57.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-50148 or the next vulnerability affects your stack