What’s Vulnerable › Vulnerabilities
CVE-2026-50168: Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-07-09
- Weakness: CWE-346
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/platform-server package allows remote attackers to bypass host allowlist constraints and direct server-side outgoing requests to arbitrary external endpoints. This occurs due to a parser differential between the strict WHATWG URL parser used for allowlist validation and the lenient Domino URL parser used to initialize the server emulated DOM. When a server-side request contains a malformed URL with a double port structure (e.g., http://evil.com:80:80/path), Node's strict URL.canParse(url) logic returns false and skips host check validation entirely. However, the same malformed URL is later accepted and parsed leniently by Domino's internal parser, which resolves the origin to http://evil.com:80. The Angular SSR HTTP request interceptor (relativeUrlsTransformerInterceptorFn) then resolves all relative backend HTTP requests against this adopted origin, executing the SSRF attack. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.
Affected products
- angular: from 2.0.0 through 18.2.14; from 19.0.0 before 19.2.23; from 20.0.0 before 20.3.22; from 21.0.0 before 21.2.15; 22.0.0-next0, 22.0.0-next1, 22.0.0-next10, 22.0.0-next11, 22.0.0-next12, 22.0.0-next2 (+9) — fixed in 19.2.23, 20.3.22, 21.2.15
How to fix
Upgrade to a fixed version: angular 19.2.23, 20.3.22, 21.2.15. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/pull/68928
- https://github.com/angular/angular/security/advisories/GHSA-xrxm-cp7j-8xf6
Get alerted when CVE-2026-50168 or the next vulnerability affects your stack