What’s Vulnerable › Vulnerabilities
CVE-2026-50169: Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-07-09
- Weakness: CWE-200
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.
Affected products
- angular: through 18.2.14; from 19.0.0 before 19.2.23; from 20.0.0 before 20.3.22; from 21.0.0 before 21.2.15; 22.0.0-next0, 22.0.0-next1, 22.0.0-next10, 22.0.0-next11, 22.0.0-next12, 22.0.0-next2 (+9) — fixed in 19.2.23, 20.3.22, 21.2.15
How to fix
Upgrade to a fixed version: angular 19.2.23, 20.3.22, 21.2.15. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/pull/67494
- https://github.com/angular/angular/security/advisories/GHSA-gv2q-mqqv-365m
Get alerted when CVE-2026-50169 or the next vulnerability affects your stack