What’s Vulnerable › Vulnerabilities

CVE-2026-50222: Apache CloudStack: Improper access control in Userdata reference APIs

Description

Missing Authorization, Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's Userdata reference APIs. Several userdata-related APIs in Apache CloudStack, including deleteUserData, linkUserDataToTemplate, resetUserDataForVirtualMachine, deployVirtualMachine, and updateVirtualMachine, exhibit missing or insufficient access control validation, potentially allowing cross-tenant/cross-account access to userdata resources that belong to other tenants. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. The deleteCniConfiguration API, introduced in 4.21.0.0, also exhibits similar behaviour and lacks access validation. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.1, 4.22.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-50222 or the next vulnerability affects your stack