What’s Vulnerable › Vulnerabilities
CVE-2026-50223: Apache OFBiz: DataResource Low-Privileged Authenticated FreeMarker Template Injection Leads to Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz allows a low-privileged authenticated user with Content/DataResource editing privileges to perform template injection attacks that could lead to Remote Code Execution. This issue affects Apache OFBiz: before 24.09.07. Users are recommended to upgrade to version 24.09.07, which fixes the issue.
Affected products
- Apache Software Foundation Apache OFBiz: before 24.09.07 — fixed in 24.09.07
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 24.09.07. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/trr2p4zokg54glqlhjnglt4yr7n8t5xd
- http://www.openwall.com/lists/oss-security/2026/06/10/13
Get alerted when CVE-2026-50223 or the next vulnerability affects your stack