What’s Vulnerable › Vulnerabilities

CVE-2026-5038: multer vulnerable to Denial of Service via incomplete cleanup of aborted uploads

Description

Impact: multer versions 2.0.0-alpha.1 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service when using diskStorage. Aborted or malformed multipart uploads leave orphaned partial files on disk because the Readable.pipe() call does not propagate the stream destroy signal to the underlying fs.WriteStream. An attacker can exhaust disk space by triggering many aborted uploads, with no application bug required. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease). Both versions track in-flight write streams and clean them up on the abort path. Workarounds: None.

Affected products

How to fix

Upgrade to a fixed version: multer 2.2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-5038 or the next vulnerability affects your stack